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Morningstar Excel Add-In 
 
 
 
 
 
 
 
 

Morningstar Add-In allows you to retrieve various types of data points from the 
Morningstar databases within Microsoft Excel for further calculation, formatting or 
charting. Thousands of widely used data points per investment type are available. 

As a Morningstar Direct user, you can dynamically retrieve Morningstar’s industry 
leading data, analytics and research. Utilize this powerful tool to easily extract 
data from one of the industry’s most comprehensive investment databases 
covering thousands of universes worldwide while also leveraging the benefits of 
Microsoft Excel. Start with a Morningstar template or your build your own, and 
quickly select any range of investments, portfolio holdings, risk measures or any 
custom data saved in Morningstar Direct. You also have the ability to incorporate 
data seamlessly into your models in Excel for further calculation, formatting, and 
charting. 
 
 

 
 
 
 
 
 
 
 

Overview 
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When accessing Morningstar Excel Add-In for the first time, you will only see the 
following icons under the Morningstar tab: 
 
 

 

 
You are required to enter your Morningstar Direct login details. To do so, do the 
following: 

1. Under the Morningstar tab, click on Profile > Direct. The Morningstar Excel Add-In 
Login dialogue box opens. 

2. Enter your Morningstar Direct e-mail address and password and click Log In. 
 
 
 
 
 
 
 
 
 
 
 

 Note: Your login details will be saved, and you will not be required to input them 
again. 

The complete Morningstar Excel Add-In toolbar is now available. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 1: Logging in for 
the first time 
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Morningstar Excel Add-In has its own settings. You can access them by doing the 
following: 

1. From the Morningstar tab, click Profile > Preferences. The Morningstar Add-In 
dialogue box opens. 

2. Under No Value Displayed, choose from the following: 
o N/A fill no data with “N/A” 
o Blank: fill no data with a blank cell 
o – : fill no data with a dash 

3. Under Morningstar Ratings and Style Box, choose to display the data as 
number/text or symbol. 

4. Under Data Retrieval Settings, choose to enable local cache, and under which 
occasion. 

5. Click OK once done. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 2: Working with 
the Add-In’s Settings 
 
 
 
 

Select from the  
available options 



Morningstar Direct 2020 
© 2020 Morningstar. All Rights Reserved. 

Exercise 3: Working with Microsoft Excel Settings Morningstar Excel Add-In 
 

 

 
8  

Morningstar Excel Add-In can pull up to 500,000 data points per day; this daily limit is 
reset at the end of the day. To avoid calculating the same data points several times 
while working on a template, do the following: 

1. Go to File > Options. The Excel Options dialogue box opens. 
2. Click on the Formula tab. 
3. Under Calculation Options, select Manual. 
4. Deselect the Recalculate workbook before saving checkbox.  
5. Click OK once done. 

 
 
 
 
 
 
 
 
 
 
 

 Note: Setting your formulas to Manual calculation will save your data while 
creating your work. You can decide to switch back to Automatic calculation at a 
later stage from the Formula tab or by going back to File > Options > Formulas. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 3: Working with 
Microsoft Excel Settings 
 
 

Set the options as 
highlighted 
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Any Investment List (or Search Criteria) created under Workspace in Morningstar Direct 
Desktop and any List or Screen created in web-based Direct can be accessed through 
Morningstar Excel Add-In. 

To use the same investments as in this exercise: 

1. Go to Morningstar Direct Desktop edition 
2. Under Workspace > Investment Lists > My List, click New 
3. Select Multiple Investments and click OK 
4. Switch the Find By drop-down to SecIds 
5. Copy the following row of SecIds: F0GBR04SGT F00000LIV1 F0GBR04PF3 

F0GBR04S23 F00000WBS9 F0GBR05VU6 
6. Right-click in the search field below and paste 
7. Click Go 
8. Click Add All and OK 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

The list displays on screen. 

9. Click Save on the Toolbar and name is My Selection. 
 
Add link to the Excel file to be used for this exercise 
 
 
 
 
 
 

Exercise 4: Creating the 
Investment List for this 
exercise  
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To select an Investment List, do the following: 

1. Select the target cell where you want to extract the data. 
2. Under the Morningstar tab, click Investments. The Morningstar Add-In dialogue 

box opens. 
3. Click the Identifiers tab. 

 
 
 
 
 
 
 
 

4. Using the Source drop-down menu, ensure Investment Lists is selected 
5. Using the List/Search name drop-down menu, select the investment list of your 

choice – My Selection in this instance. 
6. Under Layout, select Column. 
7. Under Output, deselect the Show Headers checkbox. 
8. Under Settings > Security ID, select SecId. 
9. Click Add. 
10. Click Submit. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 5: Retrieving an 
existing list of investments 
(MSMEMBER) 
 
 
 
 
 
 
 
 
 

Click on the 
highlighted options 

The resulting formula 
appears within the 
dialogue box 
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The formula used appears in the Formula bar at the top of the spreadsheet. 

 

 

 

 

 

 

 

=MSMEMBER("L","MY SELECTION","SecId","CORR=C") 

Here’s how to break it down: 

MSMEMBER – data retrieval function to pull Investment Lists and Search Criteria from 
Direct Desktop, and web-based Direct Lists and Screens. 
“L” – identifies an Investment List. “S” would identify a Search Criteria. 
“My Selection” – identifies the name of the list. 
“SecId” – identifies the identifier to be displayed. You could use ISIN instead. 
“CORR=C” – displays the identifiers in Column or Row (read “C or R = C”; in this 
instance, identifiers will be displayed in a column). 

 Note: Once you understand the formula, you can easily modify it from the grid view. 
 
 

The formula appears at 
the top of the screen 
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MSDATE (Morningstar Date) is designed for retrieving the latest date, such as last 
market close, last weekend, etc. 

These can be useful to reference as of what date the calculation in your Excel file are 
and can be used as reference for your time series formulas (MSTS). 

 Note: To see how to use this as a reference cell, please refer to ……………….. 

Here is a list of the formulas you can use: 

 

Date Short Name 

Last market close lmktclose 

Last week end lwend 

Last month end lmend 

Last quarter end lqend 

Last semi-year end lsyend 

Last year end lyend 

In the Excel file, we want to retrieve the latest month end date in cell D1 (highlighted in 
yellow in the file you downloaded). 

1. Click cell D1 
2. Type =MSDATE(“lmend”) 

The date is now displayed. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 6: Retrieving the 
latest date (MSDATE) 
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MSDP (Morningstar Supplementary Data Point) is designed for retrieving current data 
points such as fund name, Morningstar Category, etc. for a mutual fund share class. It 
requires two parameters, security identifier and data attribute identifier. 

To obtain the ISIN for our list of securities using the Investments toolbar icon, do the 
following: 

1. In the Excel spreadsheet, copy the first security’s SecId by doing CTRL + C. 
2. Under the ISIN column, select the cell corresponding to the first security in the list. 
3. From the Morningstar tab, click Investments. The Morningstar Add-In dialogue box 

opens. 
4. Under Output, deselect the Show Headers checkbox. 
5. Under the Securities tab > Attributes/Time Series tab, paste the SecId in the 

Security field by doing CTRL + V. 
 

 
 
 
 
 
 

6. Click on the security name that appears in the menu. The security name is then 
selected. 

7. Under Data Point, type ISIN and click on the name that appears in the menu to select 
it. 

 
 
 
 
 
 
 

8. Click Add. 

The resulting formula appears within the dialogue box. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 7: Displaying 
Supplementary data points 
(MSDP) 

Enter ISIN in the 
Data Point field. 

Enter the identifier in 
this field 
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9. Click Submit. The security’s ISIN displays in the Excel table. 
 
 
 
 
 
 
 
 
 
 

We now want to modify the formula and apply it to the remaining funds. To do so, do 
the following: 

1. Select cell B5. 
2. In the formula bar, replace “F0GBR04SGT;FO” with $A5 to reference the cell 

containing the security’s Secid and hit ENTER. 
3. Replace “ISIN” with B$4 to reference the discrete data point name in the header. 

 
 
 
 
 
 
 
 
 
 

4. Drag the formula down the list. Each security’s corresponding ISIN displays in the 
table. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 Note: The data points will refresh if you are on Automatic calculation mode. 

 Note: If you are on Manual calculation mode, select the cells to be calculated and 
click Cell from the Morningstar tab. 

 

Note the formula 
corresponding to 
cell B5 

Link the formula to the 
cell containing the 
security’s SecId. 

Drag the formula 
down the list 
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The table also contains the following discrete data points: 

× Name 
× Morningstar Rating Overall 
× Morningstar Analyst Rating 
× Morningstar Sustainability Rating 
× Morningstar Category 
× MPT Benchmark 
× MPT Benchmark ID 

Those headers are the names used by Morningstar Direct and the Excel Add-in and can 
be checked with the Data Dictionary. 

To access the Data Dictionary, do the following: 

1. From your Excel spreadsheet, click on the Morningstar tab. 
2. Click on Help > Data Dictionary. Your default web browser opens on screen. 
3. On the left side panel, choose Open End Fund. 
4. In the Search field, type Morningstar Category. 

You will notice two different short names for the Morningstar Category. Their use is 
determined by the Type: Discrete or Series. 

× Discrete indicates the short name to be used to retrieve discrete values, 
meaning current data points, to be used with MSDP formulas. 

× Series indicates the short name to be used to retrieve time series, meaning 
historical data points, to be used with MSTS formulas. 

 
 
 
 
 
 
 
 
 
 
 

 Note: To find out more about retrieving historical data using MSTS formulas, refer 
to Exercise 10: Working with Time Series (MSTS). 

 

 

 

 
 
 
 
 
 
 
 

Exercise 8: Working with 
the Data Dictionary 

Note the data 
point Type 
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Now that we set up the discrete data points names in the header cells and used the $ 
sign in the appropriate places to lock the identifiers and the headers, we can easily 
apply the same formula to all discrete data points columns. 

To do so, do the following: 

1. In the Excel spreadsheet, select the range of ISIN codes formulas. 
2. Place the mouse in the bottom-right corner of the range and drag to the right – all the 

way to MPT Benchmark ID. 

The data displays in the cells. 

 Note: The data points will refresh if you are on Automatic calculation mode. 

 Note: If you are on Manual calculation mode, select the cells to be calculated and 
click Cell from the Morningstar tab. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 9: Adding Multiple 
Data Points 
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MSTS is designed for retrieving data time series such as historical prices for stocks, 
NAVs for mutual funds, historical calendar period returns for securities, or historical 
portfolio data. 

Time series calculation requires 4 parameters minimum: security identifier, data 
attribute identifier, start date, end date. 

When using custom calculations, other parameters are required, such as currency, 
benchmark, source, etc. 

To retrieve performance over trailing periods using the Investments toolbar icon, do 
the following: 

1. In the Excel spreadsheet, copy the SecId of the first security by doing CTRL + C. 
2. Select the corresponding cell for your 1-Year Return and click Investments. 
3. Under Output, deselect the Show Headers checkbox. 
4. Paste the name in the Security field by doing CTRL + V. 
5. In the Data Point field, type Return and select the first choice in the list. Additional 

fields are activated in the Settings section below. 

We want to display returns in Euro and set dynamic dates for the last year from the 
latest month end. To do so, do the following: 

1. Using the Currency drop-down menu, select Euro (or your preferred currency). 
2. Using the Start Date drop-down menu, select Enter Dash Codes. 

 Note: Dash Codes is your only dynamic option. All other items in the Start Date and 
End Date drop-down menu will result in static dates in your formulas. 

3. In the field to the right, type ed-1y (end date – 1 year) 

 Note: Using ed-1y in the Start Date links it to the End Date. This means that if you 
change the end date to the last quarter end (lqend), the Start Date will automatically 
reflect 1 year from that new end date. 

4. Using the End Date drop-down menu, select Enter Dash Codes. 
5. In the field to the right, type lmend (latest month end). 
6. Using the Return Type drop-down menu, select Total. 
7. Click Add. 

 
Link to FAQ? 
 
 
 
 
 

Exercise 10: Working with 
time series (MSTS) 
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8. Click Submit. 
9. As done before, link the formula to the cell referencing the security’s SecId. 
10. Insert the $ sign to the left of A5 to lock the column reference. 

  
 
 
 
 
 
 
 
 
  

Insert the $ sign into 
the formula 

Apply Currency, 
Dates and Return 
Type as shown 
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We also want to use the MSDATE reference cell to link all our statistics to that end 
date. 

By using this single reference point, we will be able to quickly and easily change the 
end date for our time series data points in one go. 

11. In the formula, replace “lmend” with the reference cell for our MSDATE formula. 
12. To lock the end date to this cell, ensure to add $ to both the letter and the number – 

in this example: $D$1. 
 

 

 

 

 

 

 

 

13. Select your 1-year return and drag it down the column to apply it to the other 
investments in your list. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise 11: Linking an 
MSTS formula to an 
MSDATE formula 
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You can easily modify a formula from the formula bar. Let’s use our 1-year return 
formula to create the 3-year return formula. To do so, do the following: 

1. Select your 1-year return and copy it by doing CTRL + C. 
2. Select the corresponding cell under your 3-year return and paste the formula by doing 

CTRL + V (or select the 1-year return and drag it to the cell to the right). 
3. From the formula bar, change ed-1y for ed-3y (end date – 3 years). 
4. At the end of the formula, change Ann=False to Ann=True to annualise the return. 
5. Hit the ENTER key. 
6. Link the formula to the cell referencing the security’s SecId. 
7. Drag the formula down the list to apply to all securities. 

 
 
 
 
 
 
 
 

Repeat steps 1 to 6 (with ed-5y) to set up the 5-year return. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise 12: Modifying an 
MSTS formula 

 

Apply modifications 
as shown 
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We now want to set up three risk statistics using different criteria. 

To add a 3-year standard deviation, do the following: 

1. In the Excel spreadsheet, copy the first security’s SecId by doing CTRL + C. 
2. Select the corresponding cell for your 3-year standard deviation and click 

Investments. 
3. Under Output, deselect the Show Headers checkbox. Ensure Column is selected. 
4. Paste the SecId in the Security field by doing CTRL + V and click on the security’s 

name to select it. 
5. In the Data Point field, type std dev and select it from the list. Additional fields are 

activated in the Settings section below. 
6. Using the Start Date drop-down menu, select Enter Dash Codes. 
7. In the field to the right, type ed-3y (end date – 3 years). 
8. Using the End Date drop-down menu, select Enter Dash Codes. 
9. In the field to the right, type lmend (latest month end). 
10. Using the Currency drop-down menu, select Euro. 
11. In the bottom-left corner of the dialogue box, select the Annualize checkbox. 
12. Click Add and do not exit this dialogue box. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
We will now add the Tracking Error. 
 

To add a 3-year tracking error, do the following: 

1. From the Morningstar Add-In dialogue box, click on the standard deviation formula. 
2. In the Data Point field, replace Std Dev with Tracking Error. 
3. Reset the Start Date and End Date to use the Enter Dash Codes option. They will 

remember the codes used for the previous formula and they will display in both fields. 
4. In the bottom-left corner of the dialogue box, select the Annualize checkbox. 
5. In the Benchmark field, type MSCI Europe NR EUR and select it from the menu. 
6. Click Add.  

 
 
 
 
 
 
 
 
 
 

 
Exercise 13: Working with 
risk statistics 
 

Example 1: Volatility 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Example 2: Tracking Error 
 

Use the 
annualisation 
option 

Select Tracking 
Error 

Select MSCI 
Europe NR EUR 
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To add a 3-year Sharpe Ratio, do the following: 

1. From the Morningstar Add-In dialogue box, click on the Tracking Error formula. 
2. In the Data Point field, replace Tracking Error with Sharpe Ratio. 
3. Reset the Start Date and End Date to use the Enter Dash Codes option. 
4. In the bottom-left corner of the dialogue box, select the Annualize checkbox. 
5. In the Risk-Free Proxy field, type euribor 3 month and select the Euribor 3 Month 

EUR from the menu. 
6. Click Add. 

 
 
 
 
 
 
 
 
 
 

7. Click Submit. 
8. Link all three formulas to the cell referencing the security’s SecId and to the MSDATE 

reference cell. 
9. Drag the formulas down the list to apply them to all securities. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Example 3: Sharpe Ratio 

 

 

Select Sharpe 
Ratio 

Select Euribor 
3 Month EUR 
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MSTS formulas also allow for extraction of historical series, such as historical prices, 
returns, star ratings, etc. 
To extract the historical returns of our list of funds, do the following: 

1. Select the Returns tab. 
2. Select cell B2. 
3. From the Morningstar tab, click Investments. We are going to extract the 

Investment List’s SecIds in a row format. 
4. Under the Morningstar tab, click Investments. 
5. The Morningstar Add-In dialogue box opens. Click the Identifiers tab. 
6. Under Layout, select Row. 
7. Under Output, deselect the Show Headers checkbox. 
8. Using the Source drop-down menu, ensure Investment Lists is selected. 
9. Using the List/Search name drop-down menu, select the investment list of your 

choice – My Selection in this instance. 
10. Under Settings > Security ID, select SecId. 
11. Click Add. 
12. Click Submit. 

The SecIds appear in a row. 
 
 
 
 
 
 
Using the MSDP formula, we can then add the Name underneath. 

1. Click cell B3. 
2. Type =MSDP(B3,”Name”) 
3. Drag this formula to the right to display the other investments’ name. 

 
 
 
 
 
 
We now want to add daily returns for the first investment for the last year. To do so, do 
the following: 

1. Select cell B2 and copy the SecId (CTRL + C). 
2. Select cell A4 and click the Investments button. 
3. Under Attributes/Time Series, paste the SecId into the Security field (CTRL + V) and 

click on the security name when it appears in the menu. 
4. Under Data Point, type Return and select this data point. 

 
 
 
 
 
 
 
 
 
 

Exercise 14: Extracting 
Historical Series 
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5. Under Frequency, select Daily. 
6. Under Start Date, select Enter Dash Codes and type ed-1y. 
7. Under End Date, select Enter Dash Codes and type lmend. 
8. Under Sort, select Show Dates. 
9. Choose the currency and Return type of your choice. 
10. Under Days, select Calendar Days. 
11. Click Add. 
12. Click Submit. 
13. Don’t forget to link the identifier in the formula to cell B2. 

 
 
 
 
 
 
 
 
 
 
We can now apply the same formula to the second investment. 

1. Select cell A4 and copy it (CTRL + C). 
2. Select cell C4 and paste it (CTRL + V). 
3. Modify the formula by select C2 for the identifier and setting DATES = FALSE. This 

will remove the dates (which are already displayed in column A). 
4. Hit ENTER. 

You can then drag and drop this formula to the right and calculate the spreadsheet. 
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MSHOLDING is designed for retrieving holdings of portfolios. It requires at least two 
parameters to retrieve the latest holdings. 

× Portfolio IDs are Ticker, ISIN, CUSIP and SecId. 
× Position IDs define the output IDs of holdings and could be Ticker, ISIN, 

CUSIP and SecId. 

In the Excel file provided, switch to the Holdings worksheet. Notice the SecId in cell 
B1. To extract portfolio holdings, do the following: 

1. Select cell B1 and copy the SecId by doing CTRL + C. 
2. Select cell A3, where you want the data to display. 
3. From the Morningstar toolbar, click Investments. 
4. Click the Holdings tab. 
5. In the Security field, paste the SecId by doing CTRL + V. 
6. Select the security from the menu. 
7. Using the Position ID drop-down menu, select SecId (you could use ISIN instead). 
8. Under Data Type, select Weight (%). 

 Note: You can also pick Market Value or Number of Shares. 

9. Leave all other settings as is and click Add. 

 

10. Click Submit. 

 

 

 

 

 

 

 

 

 

 

 

 

 

Exercise 15: Working with 
Portfolio Holdings 
(MSHOLDING) 
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Let’s modify the formula to obtain the top 10 positions only. To do so, do the following: 

1. Select cell A3. 
2. From the Morningstar toolbar, click Investments. 
3. In the Top N Holdings field, type 10. 
4. Click Save. 

 
  
 
 
 
 
 

5.  Click Submit. 
 
 
 
 
 
 
 
 
 
 

 Note: TOP=10 has been added to the formula. 

Let’s amend the formula further and retrieve historical positions. To do so, do the 
following: 

1. Select cell A3. 
2. From the Morningstar toolbar, click Investments. 
3. Using the Start Date drop-down menu, select Enter Dash Codes. 
4. In the field to the right, type ed-1y (end date – 1 year). 
5. Using the End Date drop-down menu, select Enter Dash Codes. 
6. In the field to the right, type lmend (latest month end). 
7. Click Save. 
8. Click Submit. 
9. In the formula, replace the security identifier with the reference cell B1. 

 Note: By setting a reference cell within the formula, you just created a template. 
Typing a different SecId or ISIN in cell B1 will retrieve data for this new security. 

  

Select the top 
10 holdings 
 

The formula is 
instantly modified 
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MSOWNER is designed to retrieve ownership data. This formula can be used, amongst 
other things, to identify the funds investing in a specific security (Stock, Open-End 
Fund, ETF, etc.) over time and their market value. 

To retrieve the historical portfolio weights, do the following: 

1. In the Excel file provided, switch to the Owners worksheet. Notice the SecId 
in cell B1. 

2. Select cell B1 and copy the SecId by doing CTRL + C. 
3. Select cell A3, where you want the data to display. 
4. From the Morningstar toolbar, click Investments. 
5. Click the Ownership tab. 
6. In the Security field, paste the SecId by doing CTRL + V. 
7. Select the security from the menu. 
8. In the Ownership Data Point, type Portfolio Weighting % and click on it once it 

appears. 
9. Using the Start Date drop-down menu, select Enter Dash Codes. 
10. In the field to the right, type ed-1y (end date – 1 year). 
11. Using the End Date drop-down menu, select Enter Dash Codes. 
12. In the field to the right, type lmend (latest month end). 
13. Click Add. 
14. Click Submit. 

You can now see which fund of funds invest in this investment and the position 
weights over time. 
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