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Using Company-Level ESG data add-on 
 
 
For financial professionals looking to manage ESG risks and align to shifting investor priorities and regulatory 
requirements, Morningstar’s Company Level ESG add-on provides reliable, independent metrics, as well as supporting 
end-to-end sustainable investing workflows. 

When building portfolios with ESG considerations, you will need to understand which investments meet your portfolio’s 
sustainability objectives. Company-level ESG data allows you to screen for investments that meet a compliance or 
preference-driven threshold, understand the holdings that have biggest impact on the total portfolio aggregate, and 
monitor changes in ratings. 

In this exercise guide, you will discover how to leverage the Company-level ESG add-on to take a deep dive in portfolio 
holdings. 

 

 

 
 

Scenario 1 
You are an investment analyst and need to monitor your firm’s ESG commitment to certain exclusionary practices. funds 
which do not invest in tobacco. Create a search based on exemptions for tobacco = yes in a Morningstar Category, 
display data for tobacco, drill down to Company-level ESG data to identify the culprits. 
 
Scenario 2 
You are a portfolio manager who needs to find a new stock in the Consumer Cyclical sector, and you want to ensure it 
does not have exposure to X (maybe animal testing). Create a search using the Stocks database to find undervalued 
candidates meeting this criterion. 
 
Scenario 3 
You work for an asset management firm and have been asked to run a report on Global Large-Cap Equity funds and 
identify funds which not only outperform their peers over time, but also have a focus on sustainability and low carbon 
emissions. You will take a deep dive in the best performing funds to identify which stocks drove the overall carbon 
intensity of the funds. 
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You work as an Investment Analyst at an Asset Management firm and are tasked with 
monitoring your firm’s ESG commitment to certain exclusionary practices, such as 
tobacco in this example. 

You will use Performance Reporting to create a search based on your firm’s funds, 
display product involvement and exemptions data for tobacco, and drill down to 
company-level and use the Company-level ESG data add-on to identify the which 
stocks are involved in tobacco. 

To create a search by criteria from the Performance Reporting module, do the following: 

1. In Morningstar Direct, select the Performance Reporting tab. The Folders page is 
selected by default. 

2. From the Toolbar, click New. 
 

 
 
 
 
 
 
 
 
 
 

 
3. Select the option for Search Criteria. Be sure the Open-End Funds option is selected 

from the drop-down menu. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK. The Search Criteria dialogue box opens. 

 
 

 
 

Monitoring for your 
Firm’s ESG 
commitment 
 
 
 
 
 
Exercise 1: Creating a 
Search by Criteria in 
Performance Reporting 

 

Be sure to select this 
option to find
investments based on the
parameters you choose 

Click New 
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We want to see all Comgest funds managed by Comgest Asset Management Intl Ltd and 
use the User Defined Primary Class Only option. 

1. Select the following criteria: Branding Name = Comgest Asset Management Intl Ltd 
(or any other fund company of your choice) and tick the check box for our User Defined 
Primary Class Only option. 

2. Click OK. The Group Settings window opens on screen. 
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The interest of this report is to see how the Candriam funds fair in terms of their ESG 
commitment to Tobacco. We want to display the funds as a single group. 

To change display the funds as a single group and not under their Morningstar Category as 
per our settings, do the following 

1. Under the Group By section, select the Search radio button. Other drop-down options 
appear. 

2. Under Find Data Point By, select the Name containing radio button. A search field 
appears. 

3. Type “branding name” and click Go. Branding Name appears under the Available 
Grouping drop-down menu. 

4. Click Update. A prompt warns you that peer group and benchmark settings will be lost. 
5. Click Yes to continue. 

 
 
 
 
 
 
 
The dialogue box refreshes to display the investments under Candriam. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Exercise 2: Changing 
Group Settings 



Morningstar Direct 2021 
© 2021 Morningstar. All Rights Reserved. 

Using the Company-level ESG data add-on 
 
 
 

Exercise 3: Hiding Benchmarks 
  

  
  

9  

 
Group Settings also allows the setup of indices but for this report, we actually don’t want 
to compare with indices, so we will remove them from the report. 

To do so, do the following: 

1. From the toolbar, click Report Settings. The Report Settings window opens. 
2. Under the Group Display Settings section, deselect the checkboxes for Show display 

benchmark 1 and Show display benchmark 2. 
 
 
 
 
 

3. Under Summary Statistics Display Settings, Summary Statistics and Breakpoint 
Display Settings, ensure all checkboxes are deselected. 

 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK to return to the Group Settings window. 
5. Click OK. The Select Column window opens. 

 
 
 
 
 
 
 
 
 
 
 
 
 

6. Select User defined and click OK. The Performance Column Setup window opens. 
7. Click OK to move on to the Supplementary Columns window. 

 
 
 
 
 
 
 
 

 
Exercise 3: Hiding 
Benchmarks 
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At this stage we want to add the product involvement and exemptions data for Tobacco 
to ensure that the funds managed by your firm do follow their ESG commitments. 

We also want to display the number of holdings involved in the said product. 

Do the following: 

1. Using the Find Data Points By drop-down menu, select the Sustainability: Product 
Involvement (Fund) section. 

2. Select Product Involvement % - Tobacco and click Add. 
3. Select Product Involvement # of Holdings – Tobacco and click Add. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Using the Find Data Points By drop-down menu, select the Intentional Attributes: 
Employs Exclusion section. 

5. Select Employs Exclusions – Tobacco and click Add. 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

6. Click OK. The report opens on screen. 

 
 

 
Exercise 4: Selecting 
Product Involvement Data 
Points 
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We can now save our report and save it as a template. We will then calculate it to view 
the results. 

To save the report, do the following: 

1. From the toolbar, click Save. The Save Report window opens. 
2. Name is “Candriam ESG – Tobacco”. 
3. Click OK. 

 
 
 
 
 
 
 
 
 
 
 
 
 

Saving a report as a template is useful when you want to recreate the same report with 
another list of investments. 

To save the report as a template, do the following: 

1. From the toolbar, click the caret next to Save. 
2. Click Save as Template. The Save Template window opens. 
3. Name is “Tobacco check template”. 
4. Click OK. 

 

The report is still empty, and we need to calculate it in order to retrieve data. 

To calculate the report, do the following: 

1. From the toolbar, click Calculate. 

You are returned to the main Performance Reporting window while the report 
calculates. 

2. On the prompt, click Yes to open the report. 

You can now easily see how well funds performed against their peers over the last 10 
calendar years. 
 
 
 
 
 
 
 
 
 
 
 

 
Exercise 5: Saving a Report 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Exercise 6: Saving as 
Template 
 
 
 
 
 
 
 
 
Exercise 7: Calculating a 
Report 
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At this point in our report, we want an easy way to check if exemptions to Tobacco are 
correctly applied across the fund range. The Employs Exclusions – Tobacco will help 
identify funds that apply exclusions. 

Rather than going through the list of funds, we want an easy way to display only those 
funds with an exemption. We can use the Filter option for that. 

To apply a filter to our report, do the following: 

1. From the toolbar, click Tools > Filter > On. The Filter window opens. 
 
 
 
 
 
 
 
 
 
 

2. On row 1, click where it says “Click here to start a new filter”. 
3. Select Employs Exclusions – Tobacco. 
4. Leave Operator as =. 
5. Under Value, click in the cell and select Yes. 
6. Click OK to validate our filter options. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

You are returned to the report and your filters are applied. In the next step we will see 
how to find out which funds are actually involved with Tobacco. 

 

 

 

 

 

 
 

 
Exercise 8: Applying 
Filters to a Report 

 



Morningstar Direct 2021 
© 2021 Morningstar. All Rights Reserved. 

Using the Company-level ESG data add-on 
 
 
 

Exercise 9: Accessing Company-level Product Involvement Data 
  

  
  

13  

 
An easy way to find out which funds are involved with Tobacco is to sort on the Product 
Involvement % – Tobacco column. From there, we will be able to see if any funds are 
investing in companies involved in the Tobacco sector, identify how many holdings are 
affected, and take a dive at the company-level with the Company-level ESG data add-
on from Morningstar to see by how much. 

To proceed, do the following: 

1. Double-click the Product Involvement % – Tobacco column header twice to sort the 
data in a descending order. 

Notice how Candriam Risk Abitrage C has a product involvement of 3.51% in Tobacco. 
The Product Involvement # of Holdings – Tobacco lets us know that only 1 holding is 
involved. 

To identify which holding this is, do the following: 

2. Right-click on Candriam Risk Arbitrage C and click Investment Information > View 
Holdings > Detailed Holdings Analysis. The Holdings window opens. 

  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
Exercise 9: Accessing 
Company-level Product 
Involvement Data 

 

Right-click the 
fund name 
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Now that we are viewing the portfolio’s holdings, we can modify the data displayed in 
the grid to display the product involvement data related to Tobacco. 

To do so, do the following: 

1. From the toolbar, click Edit Data. The Select Data Points window opens. 
2. Using the View drop-down menu, select Sustainability: Product Involvement 

(Company). 
3. From the toolbar, click Edit Data. The Select Data Points window opens. 
4. Under the Selected Data Points section, select all Comp Prod Inv % data points not 

related to Tobacco and click Remove. 
5. Under the Selected Data Points section, select all Comp Prod Inv data points not 

related to Tobacco and click Remove. 
6. Using the arrows to the right, move Comp Prod Inv – Tobacco Products Production to 

be below Comp Prod Inv % – Tobacco Products Production. 
7. Using the arrows to the right, move Tobacco Products Related Products/Services to 

be below Comp Prod Inv – Tobacco Products Related Products/Services. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

8. Click Save and name it Tobacco Products. 
9. Click OK to return to the Holdings window. 
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10. Double-click each of the Comp Prod Inv column headers to identify any stocks marked 

with “Yes”. 
 
 
 
 
 
 
 
 

 

 

 

 
Any holding marked with “Yes” is used at portfolio for portfolio product involvement 
calculations. 

 Note: Portfolio level calculations are rescaled to exclude cash, derivatives, short 
positions, and synthetic ETFs. 

11. Close the Holdings window to return to your performance report. 
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You work as a Portfolio Manager who needs to find a new stock in the Consumer 
Cyclical sector, and you want to ensure it does not have exposure to Gambling. 

You will use Workspace to create a search using the Stocks database to find 
undervalued candidates meeting this criterion. (This could also be done in Performance 
Reporting.) 

To create a search by criteria from the Workspace module, do the following: 

1. In Morningstar Direct, select the Workspace tab. 
2. Click Search Criteria > My Search Criteria. 
3. From the Toolbar, click New > Advanced Search > Stocks. 

 

 
 
 
 
 
 
 
 
 
 

 
4. Select the option for Search Criteria. Be sure the Stocks option is selected from the 

drop-down menu. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK. The Search Criteria dialogue box opens. 
 
 
 
 
 
 

 

Searching for a new 
Stock 
 
 
 
 
Exercise 1: Searching for 
Consumer Cyclical Stocks 
in Workspace 

 

Click New 
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We want to select all stocks from the Consumer Cyclical sector listed in France and which 
do not have any product involvement in Gambling. 

You will need to select the following criteria: 

 

Rel Field Name Operator Value 

--- Comp Prod Inv % - Gambling Operatings = None 

And Comp Prod Inv % - Gambling Specialized Equipment = None 

And Comp Prod Inv % - Gambling Supporting 
Products/Services 

= None 

And Sector = Consumer Cyclical 

And Exchange Country = France 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

3. Click OK. Our search results display in the grid. 
4. From the toolbar, click Save and name it “Consumer Cyclical Stocks”. 
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Now that we have our selection, we can display various ESG and Carbon metrics. 

To do so, do the following: 

1. From the toolbar, click Edit Data. The Select Data Points window opens. 
2. Click Remove All to remove all data points from the Selected Data Points section. 
3. Using the Find Data Points By drop-down menu, select Sustainability: ESG Risk 

(Company). 
4. Select ESG Risk Exposure Score and click Add. 
5. Select ESG Risk Managed Score and click Add. 
6. Select Sustainalytics ESG Risk Score and click Add. 
7. Select ESG Risk Management Classification and click Add. 
8. Click Save to save your data set, name it “ESG Risk data”. 
9. Click OK to return to the grid and view the data. 
10. Double-click twice on the Sustainalytics ESG Risk Score column header to sort the 

data in an ascending order. 
 
 
 
 
 
 
 
 
 
 
 
 
 

In this instance, we notice that Valeo SA has the lowest ESG risk Score with 9.92%, and 
LVMH Moet Hennessy Louis Vuitton SE comes just after with 10.03%. 

Even though they have almost the same Sustainalytics ESG Risk Score, we see that 
their ESG Risk Exposure is quite different. Valeo SA is exposed to more risk, however 
they are doing a better job at managing it, therefore their Sustainalytics ESG Risk Score 
is lower. 

These data points are part of your Morningstar Direct subscription, but we can take a 
deeper dive with the Company-level ESG data add-on to find out where this risk is 
coming from. 

 

 

 

 

 

 

 

 

 

 
Exercise 2: Selecting 
Company-level ESG data to 
analyse ESG Risk 
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To find out how much of the ESG Risk Managed Score is actually manageable or 
unmanageable, we need to add a couple of additional data points. 

To do so, do the following: 

1. From the toolbar, click Edit > Supplementary. The Supplementary Columns window 
opens. 

2. Using the Universe drop-down menu, select Stocks. 
3. Using the Find Data Point By drop-down menu, select Sustainability: ESG Risk 

(Company). 
4. Select ESG Risk Manageable Risk Score and click Add. 
5. Select ESG Risk Unmanageable Risk Score and click Add. 
6. Click OK to return to the report. 
7. From the toolbar, click Save and name the report “Stock selection without Gambling”. 
8. From the toolbar, click Calculate to view the results. 

We previously saw that the stock with the highest ESG Risk Exposure Score is Stellantis 
NV with 47.75. From there, we have an ESG Managed Risk Score of 20.75 and a 
Sustainalitycs ESG Risk Score (also called unmanageable risk) of 27.01. 

Looking at the additional data points we added, this stock has an ESG Risk Manageable 
Risk Score of 46.67. This number is very close to the ESG Risk Exposure Score of 47.75, 
meaning that very little is unmanageable, as confirmed by the ESG Risk Unmanageable 
ESG Risk Score of 1.09. 

The ESG Risk Management Classification states this stock is Average at managing ESG 
risk. 

This is another way the Company-level ESG data Add-On can help you analyse the ESG 
risk of stocks and make a decision during your stock picking process. 
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In this exercise, you will learn how to create a report to pick funds within a category 
with a focus on sustainability and low carbon emissions. You will take then learn 
how to take a deep dive in some of those funds to identify which stocks drove the 
overall carbon intensity of the funds. 

We will use the following criteria to create our report: 

 The Global Category is Global Large-Cap Equity 
 We are looking for funds defined as low carbon/fossil fuel free in their 

prospectus 
 We will use the user defined primary share class only option 
 We will include the Morningstar Rating Overall in our search to exclude funds 

without a rating. This also enables us to ensure we have funds with a minimum 
of 3 years history. 

To create a search by criteria from the Performance Reporting module, do the following: 

1. In Morningstar Direct, select the Performance Reporting tab. The Folders page is 
selected by default. 

2. From the Toolbar, click New. 
 

 
 
 
 
 
 
 
 
 
 
 
 

3. Select the option for Search Criteria. Be sure the Open-End Funds option is selected 
from the drop-down menu. 

 

 
 
 
 
 
 
 
 
 
 
 
 

4. Click OK. The Search Criteria dialogue box opens. 

 

 

 

 

 

Searching for Low 
Carbon funds 
 
 
 
 
 
 
 
 
 
 
 
 
Exercise 1: Creating a 
Search by Criteria in 
Performance Reporting 

 

Be sure to select the
correct tab and icon 

Be sure to select this 
option to find
investments based on 
the parameters you 
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Set your criteria as shown in the following table: 
 

Rel Field Name Operator Value 

-- Global Category = Global Equity Large Cap 

And Sustainable Investment – Low Carbon/Fossil-
Fuel Free 

= Yes 

And Morningstar Rating Overall Not = NA 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

5. Select the User Defined Primary Class Only checkbox. This can be defined under File 
> Set User Preferences > User Defined Primary tab. 

6. Click OK. The Group Settings dialogue box opens. 

 

Be sure your search
reflects the inputs here 

Select User Defined 
Primary Class Only 
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By default, when examining the performance of the funds in the search results, 
Morningstar Direct groups the funds by Morningstar Category (unless if you changed 
the default under General Settings. 

In this case, we want to compare all funds at the Global Category level. 

To do so, do the following: 

1. Under Group By, click the Search radio button. 
2. Using the Find Data Point By drop-down menu, select Global Category. 

 

 

 

 

 

 

 

 

 

 

 

 

 

3. Click Update. 
 

 
 
 
 
 
 
 
 
 
 

1. Click OK. The Select Column dialogue box appears. 
2. Select User Defined and click OK. The Performance dialogue box appears. 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
Exercise 2: Working with 
Group Settings 

 
 

Select this option to 
group funds by 
Global Category 

Funds are grouped by 
Global Category 
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To see the consistent performance of this set of funds, you should examine multiple 
time periods. In this case, you will examine the funds’ performance and how they fare 
against the category average for the trailing 6 months, 1 and 3 years. 

To set the values for the Time Periods, do the following: 

1. Ensure the option for Single period is selected. 
2. From the Start Date field, select 5 Years ago.  
3. From the End Date field, select Last Month End. 
4. Click Add Columns. 
5. In the Selected Time Periods section, double-click the date to rename it. 
6. You can double-click the added time period and change the label to “5 Years”. 

 Note: Do not click OK yet; the Data Points and Ranks tabs still need to be addressed. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

 

 

 

 

 

 

 

 

 

 
Exercise 3: Setting the 
Values for the Time Periods 
tab 

 

 

Use this button to add
the time period  
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To set the values for the two remaining tabs in the Performance Column Setup 
dialogue box, do the following: 

1. Click the Data Points tab; only Return is selected. 

 Note: Return is already our default statistic for all time periods. 

 

 
Exercise 4: Setting the Values 
for the Data Points and Ranks 
tabs 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

Return is the 
default statistic 

Be sure to select
the correct tab 
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2. Click the Ranks tab; remove Peer group percentile and add Peer group quartile. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. Click OK to close the Performance Column Setup dialogue box. The Supplementary 
Columns dialogue box opens next. 

Be sure to select
the correct tab 

This option is selected by default 
and ensures the selected rank is 
added to the same statistics 
under all time periods 
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In addition to seeing the name of a fund in the performance report, it will also be 
useful to include the fund’s ISIN. To include a fund’s ISIN in the performance report, 
do the following: 

1. Using the second drop-down menu, select the Sustainability: ESG Risk (Fund) section 
and add the following data points: 

 Morningstar Sustainability RatingTM 
 Historical Sustainability Score 

2. Select the Sustainability: Carbon Risk (Fund) section and add the following data 
points: 

 Low Carbon DesignationTM 
 12 Month Average Carbon Risk Score 
 12 Month Average Fossil Fuel Exposure 
 Emissions Scope 1 
 Emissions Scope 2 
 Stranded Assets Risk 

4. From the toolbar, click Save and name it “Low Carbon Global Equity Large Cap”. 
5. Click OK to return to the report. 
6. From the toolbar, click Calculate to view the results. 
7. On the prompt, click Yes to open the report. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Exercise 5: Selecting ESG 
and Carbon Data 
 
 
 
 
 
 
 



Morningstar Direct 2021 
© 2021 Morningstar. All Rights Reserved. 

Using the Company-level ESG data add-on 
 
 
 
 

Exercise 6: Sorting on two Columns 
  

  
  

27  

 
We now see the results of our report and want to sort to see the funds sorted by top 
quartile (ascending order) and Morningstar Sustainability RatingTM (descending order). 

This will allow us to quickly identify 5-globes funds within the top quartile over the last 
5 years. 

To do so, do the following: 

1. From the toolbar, click Edit > Sort. 
2. Using the Primary Rank drop-down menu, select 3 years: Peer group quartile. 
3. Set the order to Ascending. 
4. Using the Secondary Rank drop-down menu, select Morningstar Sustainability 

RatingTM. 
5. Set the order to Descending. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

6. Click OK. 

The report is now sorted on the funds in the 1st quartile over the last 3 years and their 
Morningstar Sustainability RatingTM. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Exercise 6: Sorting on two 
Columns 
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Note how all 5-globe rated funds within the 1st quartile have the Low Carbon 
DesignationTM. With access to the Company-level ESG data add-on, we can take a 
deeper dive at these portfolios to see the holdings’ carbon overall risk score, emissions, 
and much more. 

To access a fund’s holdings, do the following: 

1. Right-click on the first fund in the list. A pop-up menu appears. 
2. Click Investment Information > View Holdings > Detailed Holdings Analysis. The 

Holdings window opens. 
 
 
 
 
 
 
 
 
 
 
 
 
 

3. From the toolbar, click the 2nd drop-down menu (where Snapshot is selected by default) 
and select Sustainability: Carbon Risk (Company). The Carbon Risk data displays on 
the grid. 

From there, you can see the Carbon Overall Risk Score (lower is better) of the 
constituents, their risk classification, manageable and managed risk scores, as well as 
carbon emissions amongst other things. 
 
 
 
 
 
 
 
 
 
 
 
 

 
Exercise 7: Accessing 
Carbon Data at Holdings 
level 
  

Right-click on 
the fund name 



Morningstar Direct 2021 
© 2021 Morningstar. All Rights Reserved. 

Using the Company-level ESG data add-on 
 
 
 
 

Exercise 7: Accessing Carbon Data at Holdings level 
  

  
  

29  

 
With the Company-level ESG data add-on, you can also access carbon involvement, 
which will identify which holdings are taken into account for the Fossil Fuel 
Involvement calculations. 

To display the carbon involvement data, do the following: 

1. From the toolbar, click the 2nd drop-down menu and select Sustainability: Carbon 
Involvement (Company). The Carbon Involvement data displays on the grid. 

This data set provides the aggregated involvement percentage based on revenues for a 
company with involvement in Fossil Fuel areas. From there you can sort on the columns 
to see which holdings have the biggest involvement in a specific area and discover 
which holdings are the biggest driver for the Fossil Fuel Exposure at portfolio level. 

2. Close the Holdings window to return to your performance report 
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