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Constructing a Model Portfolio 
 
 
 
 
 
 
 
 

In this exercise guide, you will learn how to leverage some of the key features in 
Morningstar Direct, including the following tasks: 
 
 Build your own portfolio from an Investment List 
 Modify an existing portfolio 
 How to handle Cash positions 

 
 
 
 
 
 
 
 

Overview 
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The first step in creating a portfolio is to identify its investments. Once you have gone 
through your selection process, you can save those investments in an Investment 
List for easy access. 

There are 3 main sections in Portfolio Management: Model Portfolios (for your 
portfolios, Custom Benchmarks (for mixed indices), and Accounts (for returns series 
or holdings import). The process for creating either item is similar. 

We will be working with the Model Portfolios section. To create a new Model 
Portfolio, do the following: 

1. In Morningstar Direct, select the Portfolio Management tab. The Accounts section is 
selected by default. 

2. Click on Model Portfolios. 
3. From the toolbar, click New. 

 
 
 
 
 
 
 
 
 
 
 
 

4. Enter/select the highlighted information:  
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 1: Creating a 
Model Portfolio  

Be sure to select 
the correct tab and 
icon 

Enter/select information 
as appropriate 
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5. Choose your rebalancing frequency. In this exercise, we will use the information in bold. 

 

Rebalancing 
Frequency 

Rebalancing based 
on 

Performance Calculation 
Start Date 

Missing TNA Handling 

Buy and Hold - Enter the date of those positions 
in the Holdings Entry dialogue 
box 

 

Monthly/Daily
/Quarterly/ 
Semi-
Annually/Annu
ally 

Calendar Period End: on 
the end period date (E.g; 
month end if monthly if 
monthly is selected) 

Rolling Period based on 
Portfolio Date: on the 
same day in the next 
period 

First Portfolio Date: select 
specific date 

Earliest Available: date of the 
inception date of the oldest 
constituent 

Earliest Common: common period 

 

Monthly – 
Total Net 
Assets 

- - Infer forward in time 

Infer backward in time 

Roll previous value forward 

Buy and Hold 
– Total Net 
Assets 

- 

 

- Infer forward in time 

Infer backward in time 

Roll previous value forward 
 

 Note: Rebalancing with Monthly – Total Net Assets means the portfolio is rebalanced 
each month in proportion to the TNAs of the share classes as of that month end. 

 Note: Rebalancing with Buy and Hold – Total Net Assets means the weightings are 
automatically updated as the latest month end date changes. 

6. Click Save. The Holdings Entry dialogue box opens. 

 Note: Regarding benchmarks: you have access to the Market Indexes database, as 
well as access to Morningstar Indices. 

 Note: As mentioned earlier on in this document, Portfolio Management also allows 
you to create your own Custom Benchmarks. You can therefore go to Portfolio 
Management > Custom Benchmarks and create your own mixed index, following 
the same instructions as to create a Model Portfolio. 
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You are now able to select the investments for your Model Portfolio. You can select 
investments from an existing Investment List, or simply select your funds by looking 
for their ISIN or SecId. 

 Note: It is recommended to use SecId (unique identifier) when working with 
investments such as ETFs or currency share classes that have the same ISIN as 
identifier. 

There are three main tabs in the Holdings Entry dialogue box: 

× Stock/Fund: select from the Stocks and Funds databases 
× Fixed Income: select from the Bonds database 
× Cash: select custom cash securities (set up in Security Definition Master) 

To select investments, do the following:  

1. Under the Stock/Fund tab, click Add. The Add Holdings dialogue box opens. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. At the top of the dialogue box, switch the Find By drop-down menu to ISIN. 

 Note: You can also select My Lists or My Searches. 

3. Select the following ISINs: 
 

ISIN Name Universe 
IE0008365730 AXA Rosenberg Pan-Erup Eq Alpha A EURAcc Open-End Funds 
LU0171283459 BGF Global Allocation A2 Open-End Funds 
BE0174191768 Candriam Sust Pacific C JPY Cap Open-End Funds 
GB0003875100 Fidelity Special Situations Open-End Funds 
LU1240328812 Invesco Euro Equity A EUR Acc Open-End Funds 
LU0194781224 Invesco Pan Eurp Struct Rspnb Eq EEURAcc Open-End Funds 
LU0085136942 Robeco High Yield Bonds DH € Open-End Funds 
DE000A0F5UH1 iShares STOXX Global Sel Div 100 (DE) ETFs 

 
 Note: for the iShares, select the one marked as Oldest, this will be the primary 

exchange. 

4. Click OK to return to the Holdings Entry window. 

 

Exercise 2: Selecting 
Constituents 

 

Click here to select 
investments 
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Back on the Holdings Entry dialogue box, we want to add some cash to our portfolio. 
But we first need to create the cash position in Security Definition Master in order for it 
to be recognised in the right currency. 

To create a cash position, do the following: 

1. From the Holdings Entry window, click the Cash tab. 
2. Click Edit Definition Master. The Definition Master window opens on screen. 
3. From the toolbar, click Security Wizard. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

4. Under Security Type, select Cash and Cash equivalents. 
5. In the Description, CUSIP, ISIN, and Symbol fields, type Cash EUR. 
6. Under Base Currency, select Euro Member Countries, Euro. 

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 
7. Click Save + Close and click OK on the prompt. 

 

 

 
Exercise 3: Creating a 
Custom Cash Position 

 

 

Click Security 
Wizard 

Enter the 
information as 
shown here 
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You are returned to the Definition Master window. Note the new Cash position in Euro 
currency. 

 

 

 

 

 

 

 

 

 

 

 

 

8. Close the window to return to the Holdings Entry window. 
9. Click Add. The Add Holdings dialogue box opens. 
10. In the Search field, type cash eur, click Go. 
11. Select your custom cash and click Add. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

12. Click OK.

Add your 
cash 
position 
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Back in the Holdings Entry window, we can now allocate weights to our positions. 

1. Assign 5% to your cash. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

2. Click the Stock/Fund tab. 
3. Assign the following weights to the remaining holdings: 

 
Fund Weight 

AXA Rosenberg Pan-Eurp Eq Alp A EUR 12.5 

BGF Global Allocation A2 10 

Candriam Sust Pacific C Acc 15 

Fidelity Special Situations 10 

Invesco Euro Equity A EUR Acc 12.5 

Invesco European Growth Equity E 10 

iShares STOXX Global Sel Div 100 (DE) 15 

Robeco High Yield Bonds DH EUR 10 

Cash EUR 5 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Exercise 4: Assigning 
Weights to your Positions 
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4. Using the calendar next to Position as of, set the date to 01/01/2016. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 Note: You can enter positions by weight, amount or number of shares. To do so, click 
Enter By and select the appropriate option. 

5. Click Finish. 

Your portfolio is now saved and opens on screen. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 

 
 

 

Enter weights and 
set the date to 
01/01/2016 
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We now want to record a change in our portfolio over time. We will therefore create 
a new date with the composition of the portfolio on this date and time. 

To record a change in the portfolio, do the following: 

1. From the toolbar in your Model Portfolio window, click on the arrow next to Edit > New 
Portfolio. 

 

 
 
 
 
 
 
 
 
 
 

6. The Portfolio Date Selection dialogue box opens. 
7. Enter the date of the change in positions allocation: 15/06/2016. 
8. Select Modify Constituents from an Existing Portfolio to copy the previously selected 

constituents. 
9. Select Retain Weights to work with weights. 
10. Choose the original portfolio date you want to work with (only one in this case). 
11. Click OK. 

 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

 
 
 
 
 
 
 
 
 
 

 

Exercise 5: Recording a 
Change in the Portfolio 
Composition

Click on the arrow and 
then on New Portfolio 

Use the highlighted 
options 
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You are taken back to the Holdings Entry dialogue box. We want to remove the last 
security from our portfolio. 

 
12. Tick the checkbox next to the name of the last security in your list. 
13. Go to Action > Delete Rows. 

  
 
 
 
 
 
 
 
 
 
 
 
 
 
 

14. Assign 15% to Fidelity Special Situations and BGF Global Allocation A2. 
15. Click Finish. 

The change in portfolio composition has now been recorded. You can use the Portfolio 
drop-down menu to toggle between the dates. 
 
  
 
 
 
 
 
 
 
 
 

Close the Model Portfolio window by clicking on the red cross in the top-right corner. 
You are taken back the Model Portfolios section of Portfolio Management. 

Use the 
highlighted 
options 

Use this drop-down 
menu to toggle 
between dates 
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We now want to see how this portfolio fairs against its benchmark in a growth chart. 

To do so, do the following: 

1. Tick the checkbox next to the portfolio you created. 
2. Go to Action > Interactive Charts > Desktop-based Charts > Growth. 

 
 

Exercise 6: Generating a 
Growth chart 

 
 

 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 

 
The Growth chart displays your portfolio as well as the benchmark you selected. 
Various options are available to customise the data, such as Chart View, Initial Value, 
Time Range, Currency, etc. 
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You can easily generate a report for further quick analysis of your Model Portfolio. This 
report will give an overview of the portfolio exposure, risk and return, as well as the top 
25 stocks within your portfolio. 

To generate this report, do the following: 

1. From Portfolio Management > Model Portfolios, tick the checkbox next to your 
portfolio name. 

2. Go to Action > Reports > Portfolio Aggregation. 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
The Portfolio Aggregation dialogue box opens. You will notice how the relevant 
Benchmark, Risk-Free rate and Currency assigned to the portfolio are selected. 
You may decide to add a summary page for each constituent of your portfolio from 
the Append constituent summary page drop-down menu. 

You can also select partial or all sections of the report. 

3. Leave all options as shown in the screenshot below and click OK. 
4. Click No on the prompt. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

Exercise 7: Generating the 
Portfolio Aggregation report 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Select the Portfolio 
Aggregation report 

The Benchmark, Risk-Free rate 
and Currency settings are 
automatically filled in 

Choose which 
information to display 
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The Portfolio Aggregation report opens. You can save it by clicking on the Save 
icon that appears when hovering on the top of the page.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Hover at the top of the 
page to save the report 
to your computer 
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An Import function is also available for Model Portfolios. This function can save you 
a tremendous amount of time in creating new Model Portfolios or updating existing 
ones. We are going to record additional changes over time for our current Model 
Portfolio. 

To do so, you need to create an Excel file with the following information: 

× Date – date of the positions 
× Portfolio Name – name of your portfolio 
× Portfolio ID – identifier you entered under General Settings 
× Identifier – constituent’s identifier 
× Holdings – constituent’s name 
× Weight (%) – percentage of the position 

 Note: You can also work with Number of Shares/Amounts instead of Weights. 

 

 

 

 

 

 

 

 

 

 

 

 

 

The file contains positions for the same portfolio, but with two different dates, 
which indicates a change in the positions on two different occasions. 

To proceed with the import, do the following: 

1. Download the file used in this exercise by clicking here. 
2. From the Portfolio Management module under the Model Portfolios section, 

click Import. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Exercise 8: Using the Import 
function 

 
 
 

Click on Import 

Note the various 
dates, indicating 2 
changes in our 
portfolio 

The Portfolio Name 
and Portfolio ID 
ensure the correct 
Model Portfolio is 
updated 

https://advisor.morningstar.com/AWSOE/Training/PortfolioManagement/ModelPortfolioImport_EMEA.xlsx
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3. From the Import window, double-click on Model Portfolio Holdings. The Model 

Portfolio Holdings dialogue box opens. 
4. File Name: browse to select your saved Excel file. 
5. Date format: select the relevant format. 
6. Weight format: in this example, we will select Percentage Format. 
7. Security ID Type can be left on Auto Detect. 
8. Header Row checkbox: leave it selected if your Excel file contains a header row. 
9. Map the Column Code with the Column No. columns. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
10. Click on Import and the Blotter opens. 

Select your file and any 
relevant settings 

Click on the relevant 
row in the right column 
and a drop-down menu 
opens to map items 
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The Blotter is a temporary space where your positions are held until you validate the 
information. 

You will be notified of any errors or inconsistencies. In this example, a new user-
defined security is highlighted in the left panel. 

To work with user-defined securities, do the following: 
1. From the Securities section, click New User-Defined Securities. 

 
The iShares STOXX Global ETF is flagged in red with a warning sign. 

When importing stocks and ETFs, you will be prompted to map the exchange for that 
particular investment. Once done, this will be mapped in Security Definition Master and 
you will not be required to do this again for this Model Portfolio. 

2. Double-click on the red warning sign. The Select the matching security window opens. 

 Note: The Representative Performance Stream column identifies the primary listing 
for this ETF. 

3. Select the primary class, indicated by a Yes under the Representative Performance 
Stream column. 

 Note: If you click Save as User-Defined, this will be saved in Definition Master and 
the system will remember this information during the next import for this model 
portfolio. 

4. Click OK. 

 

 

 

 

 

 

 

 

Exercise 9: Mapping 
Securities 
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5. Click Save. 

A prompt confirms the changes were saved, and there is no more warning under New 
User-Defined Securities on the left navigation panel. 

6. From the toolbar, click Post. 
7. When prompted, click OK and close the Import window by clicking on the red cross in 

the top-right corner. 

You are taken back to the Model Portfolios section. 

Open your portfolio and notice how the dates were successfully recorded. 
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Stocks and ETFs are listed on multiple exchanges in the Morningstar Database. 

When importing this type of investments using ISIN, you will be prompted to select the 
right exchange during the import process, as seen in Exercise 9: Mapping Securities. 

Morningstar Direct offers a couple of options to deal with situation when importing 
Model Portfolios: 

× Use SecId as identifier during import: an ETF/Stock listed on multiple exchanges 
will have a different SecId depending on the exchange it’s listed on. By using 
the SecId as identifier for the ETF/Stock on the specific exchange you require in 
your import file, Morningstar Direct will automatically select the appropriate 
exchange. 

 

 

 

 

 

 

 

 

 

 

 

× Use the ETF/Stock listed on the primary exchange. There is an option you can 
select to automate this process: 

1. Go to File > Set User Preferences > Import tab. 
2. Select the checkbox for Auto-Select Representative Performance Stream 

Investments. 

This option will automatically select ETFs and Stocks on their primary listing when 
importing Model Portfolios. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Appendix A: Tips when 
Importing ETFs and Stocks 
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× Another option is to apply filters for Exchanges and Currencies when running an 
import. 

When importing a model portfolio with ETFs/Stocks on various exchanges, you can 
assign a preferred order in your exchange and currency selection. 

To use this function, do the following: 

1. Go to File > Set User Preferences > Import tab. 
2. Under the Choose your investment matching filter settings, click Set Exchange Filter. 
3. Click Add/Remove Exchanges. 
4. As an example, select the following exchanges: 
 Euronext Paris S.A., FRA 
 Euronext Amsterdam, NLD 
 Borse Berlin – Freiverkehr, DEU 

5. Select Import Match. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

By setting up those filter options, any ETFs/Stocks listed on those exchanges will be 
mapped to them during import, in order of preference. 

You could apply a similar mapping by currencies, which can be useful for multi-
currency open-end funds sharing the same ISIN. 
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A Combined Series option exists for Accounts, Model Portfolios and Custom 
Benchmarks, but this tends to be more used for Custom Benchmarks. 

Combined Series deal with manipulating return series rather than having holdings with 
different weights or market values like a traditional model. 

The Combined Series options are as follows:  

 Arithmetic Addition/Subtraction: add or subtract the returns of two series 
(usually used for combining indexes). For example, the S&P 500 returns 12% and 
the US Agg returns 2%. The combined series of these two would show a return 
of 14%.  

 Geometric Addition/Subtraction: same as the above except that it takes 
compounding into account. 

 Arithmetic Addition/Subtraction of a Constant: take a base series (usually an 
index) and add or subtract a constant value. This can be applied daily, monthly, 
quarterly, semi-annually or annually. For example, Euribor 3 Months returns +/- 
2%. 

 Geometric Addition/Subtraction of a Constant: same as the above except that it 
takes compounding into account. 

 Currency Hedging: using derivatives to eliminate (hedge away) the risk of 
currency rates changing. 

 Note: Important side note: Combined Series models cannot be added as a holding in 
another model. For weighted blends, you would create a non-combined series model 
and add the two underlying models as holdings, weighting them, for example, at 60% 
and 40%. 

As an example, we will create an addition of 2% annually to a risk-free rate. Do the 
following: 

1. From the Portfolio management module, click Custom Benchmarks. 
2. Click New. The Benchmark Basics window opens. 
3. In the Name field, type “Euribor +2%”. 
4. Under Combined Series, click the Yes radio button to activate this function. 

 Note: As you activate this function, all options under the Combined Series: No 
section are greyed out. 

5. Under Base Series, click the magnifying glass. The Select Series window opens. 
6. In the Find By search field, type “Euribor 3 m” (or any other risk-free name of your 

choice). 
7. Click Go. 
8. Select Euribor 3 Month EUR. 
9. Click OK. You are returned to the Benchmark Basics window. 

 
 
 
 
 
 
 
 
 

Appendix B: Using 
Combined Series 
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10. Using the Operator drop-down menu, select Arithmetic addition of a constant. The 
Constant % field appears. 

11. In the Content % field, type 2. 
12. Using the Per drop-down menu, select Annually. 

 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

13. Click Save. 

You have now created a custom benchmark composed of a risk-free rate +2% annually. 

 

 

 

 

 

 

 

 
 

Select options as 
shown here 
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